summaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index 3e5ccdd..096769e 100644
--- a/flake.nix
+++ b/flake.nix
@@ -2,8 +2,13 @@
description = "Development shell for aoc2024";
inputs = {
+ nixpkgs = {
+ url = "github:nixos/nixpkgs/nixos-unstable";
+ };
+
flake-utils = {
url = "github:numtide/flake-utils";
+ inputs.nixpkgs.follows = "nixpkgs";
};
};
@@ -11,11 +16,11 @@
flake-utils.lib.eachDefaultSystem (system:
let
pkgs = import nixpkgs { inherit system; };
+ beamPkgs = with pkgs.beam_minimal; packagesWith interpreters.erlang_27;
in {
devShells.default = pkgs.mkShell {
buildInputs = [
- pkgs.elixir
- pkgs.elixir-ls
+ beamPkgs.elixir_1_17
];
};
});