diff options
author | Alexandre Jesus <adbjesus@gmail.com> | 2024-12-07 13:34:49 +0000 |
---|---|---|
committer | Alexandre Jesus <adbjesus@gmail.com> | 2024-12-07 13:34:49 +0000 |
commit | 8362e80cbdda472c2a92d9566e511cbce5a9ecf5 (patch) | |
tree | cea27d6deea131112160108543499b887cd3dd3c /flake.nix | |
parent | 368feac2eb23657ae2de72b8ed6a2366fd1cbe3e (diff) | |
download | aoc2024-8362e80cbdda472c2a92d9566e511cbce5a9ecf5.tar.gz aoc2024-8362e80cbdda472c2a92d9566e511cbce5a9ecf5.zip |
Day 6
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 9 |
1 files changed, 7 insertions, 2 deletions
@@ -2,8 +2,13 @@ description = "Development shell for aoc2024"; inputs = { + nixpkgs = { + url = "github:nixos/nixpkgs/nixos-unstable"; + }; + flake-utils = { url = "github:numtide/flake-utils"; + inputs.nixpkgs.follows = "nixpkgs"; }; }; @@ -11,11 +16,11 @@ flake-utils.lib.eachDefaultSystem (system: let pkgs = import nixpkgs { inherit system; }; + beamPkgs = with pkgs.beam_minimal; packagesWith interpreters.erlang_27; in { devShells.default = pkgs.mkShell { buildInputs = [ - pkgs.elixir - pkgs.elixir-ls + beamPkgs.elixir_1_17 ]; }; }); |