summaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..3e5ccdd
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,22 @@
+{
+ description = "Development shell for aoc2024";
+
+ inputs = {
+ flake-utils = {
+ url = "github:numtide/flake-utils";
+ };
+ };
+
+ outputs = { self, nixpkgs, flake-utils }:
+ flake-utils.lib.eachDefaultSystem (system:
+ let
+ pkgs = import nixpkgs { inherit system; };
+ in {
+ devShells.default = pkgs.mkShell {
+ buildInputs = [
+ pkgs.elixir
+ pkgs.elixir-ls
+ ];
+ };
+ });
+}