diff options
author | Alexandre Jesus <adbjesus@gmail.com> | 2023-08-01 13:11:58 +0100 |
---|---|---|
committer | Alexandre Jesus <adbjesus@gmail.com> | 2023-08-01 13:11:58 +0100 |
commit | 6fe1e93a34aed2b3bcd98b5fb6bc1c8c1790d2e7 (patch) | |
tree | b4f5ce45dcc8011f30444711764ebbd31606fc44 /flake.nix | |
parent | 264f9b94f2ae416cf80e540ee38d8f5171c24808 (diff) | |
download | adbjesus.com-6fe1e93a34aed2b3bcd98b5fb6bc1c8c1790d2e7.tar.gz adbjesus.com-6fe1e93a34aed2b3bcd98b5fb6bc1c8c1790d2e7.zip |
Remove unecessary flake-utils
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 54 |
1 files changed, 22 insertions, 32 deletions
@@ -1,26 +1,26 @@ { - description = "My personal website"; + description = "adbjesus.com website"; inputs = { nixpkgs = { url = "github:nixos/nixpkgs/nixos-23.05"; }; - - flake-utils = { - url = "github:numtide/flake-utils"; - }; }; - outputs = { self, nixpkgs, flake-utils }: - flake-utils.lib.eachDefaultSystem (system: - let - pkgs = import nixpkgs { inherit system; }; - in rec { - packages.website = pkgs.stdenv.mkDerivation { - name = "website"; - src = self; - - buildInputs = [ pkgs.zola ]; + outputs = { self, nixpkgs }: + let + systems = [ "x86_64-linux" ]; + forAllSystems = function: + nixpkgs.lib.genAttrs systems (system: function nixpkgs.legacyPackages.${system}); + in rec { + packages = nixpkgs.lib.genAttrs systems (system: { + adbjesus-website = nixpkgs.legacyPackages.${system}.stdenv.mkDerivation { + name = "adbjesus-website"; + src = ./.; + + buildInputs = with nixpkgs.legacyPackages.${system}; [ + zola + ]; buildPhase = '' zola build @@ -32,24 +32,14 @@ ''; }; - packages.default = self.packages.${system}.website; - - apps.default = flake-utils.lib.mkApp { - drv = pkgs.writeShellApplication { - name = "serve"; + default = self.packages.${system}.adbjesus-website; + }); - runtimeInputs = [ pkgs.zola ]; - - text = '' - zola serve - ''; - }; - }; - - devShells.default = pkgs.mkShell { - inputsFrom = [ self.packages.${system}.website ]; + devShells = nixpkgs.lib.genAttrs systems (system: { + default = nixpkgs.legacyPackages.${system}.mkShell { + inputsFrom = [ self.packages.${system}.adbjesus-website ]; }; - } - ); + }); + }; } |